aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/nftables/patches
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/nftables/patches')
-rw-r--r--package/network/utils/nftables/patches/001-examples-compile-with-make-check.patch29
-rw-r--r--package/network/utils/nftables/patches/001-parser-allow-quoted-string-in-flowtable_expr_member.patch44
2 files changed, 29 insertions, 44 deletions
diff --git a/package/network/utils/nftables/patches/001-examples-compile-with-make-check.patch b/package/network/utils/nftables/patches/001-examples-compile-with-make-check.patch
new file mode 100644
index 0000000000..6a4430d86f
--- /dev/null
+++ b/package/network/utils/nftables/patches/001-examples-compile-with-make-check.patch
@@ -0,0 +1,29 @@
+From 18a08fb7f0443f8bde83393bd6f69e23a04246b3 Mon Sep 17 00:00:00 2001
+From: Pablo Neira Ayuso <pablo@netfilter.org>
+Date: Tue, 22 Feb 2022 00:56:36 +0100
+Subject: examples: compile with `make check' and add AM_CPPFLAGS
+
+Compile examples via `make check' like libnftnl does. Use AM_CPPFLAGS to
+specify local headers via -I.
+
+Unfortunately, `make distcheck' did not catch this compile time error in
+my system, since it was using the nftables/libnftables.h file of the
+previous nftables release.
+
+Fixes: 5b364657a35f ("build: missing SUBIRS update")
+Fixes: caf2a6ad2d22 ("examples: add libnftables example program")
+Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
+---
+ examples/Makefile.am | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -1,4 +1,6 @@
+-noinst_PROGRAMS = nft-buffer \
++check_PROGRAMS = nft-buffer \
+ nft-json-file
+
++AM_CPPFLAGS = -I$(top_srcdir)/include
++
+ LDADD = $(top_builddir)/src/libnftables.la
diff --git a/package/network/utils/nftables/patches/001-parser-allow-quoted-string-in-flowtable_expr_member.patch b/package/network/utils/nftables/patches/001-parser-allow-quoted-string-in-flowtable_expr_member.patch
deleted file mode 100644
index 3090adec25..0000000000
--- a/package/network/utils/nftables/patches/001-parser-allow-quoted-string-in-flowtable_expr_member.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From 07af4429241c9832a613cb8620331ac54257d9df Mon Sep 17 00:00:00 2001
-From: Stijn Tintel <stijn@linux-ipv6.be>
-Date: Tue, 21 Dec 2021 12:40:25 +0200
-Subject: [PATCH] parser: allow quoted string in flowtable_expr_member
-
-Devices with interface names starting with a digit can not be configured
-in flowtables. Trying to do so throws the following error:
-
-Error: syntax error, unexpected number, expecting comma or '}'
-devices = { eth0, 6in4-wan6 };
-
-This is however a perfectly valid interface name. Solve the issue by
-allowing the use of quoted strings.
-
-Suggested-by: Jo-Philipp Wich <jo@mein.io>
-Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
-Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
----
- src/parser_bison.y | 9 ++++++++-
- 1 file changed, 8 insertions(+), 1 deletion(-)
-
-diff --git a/src/parser_bison.y b/src/parser_bison.y
-index 16607bb7..1136ab91 100644
---- a/src/parser_bison.y
-+++ b/src/parser_bison.y
-@@ -2151,7 +2151,14 @@ flowtable_list_expr : flowtable_expr_member
- | flowtable_list_expr COMMA opt_newline
- ;
-
--flowtable_expr_member : STRING
-+flowtable_expr_member : QUOTED_STRING
-+ {
-+ $$ = constant_expr_alloc(&@$, &string_type,
-+ BYTEORDER_HOST_ENDIAN,
-+ strlen($1) * BITS_PER_BYTE, $1);
-+ xfree($1);
-+ }
-+ | STRING
- {
- $$ = constant_expr_alloc(&@$, &string_type,
- BYTEORDER_HOST_ENDIAN,
---
-2.33.1
-