aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/nftables/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/nftables/Makefile')
-rw-r--r--package/network/utils/nftables/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/network/utils/nftables/Makefile b/package/network/utils/nftables/Makefile
index 9a180a0953..55a6a4bcf6 100644
--- a/package/network/utils/nftables/Makefile
+++ b/package/network/utils/nftables/Makefile
@@ -20,6 +20,8 @@ PKG_LICENSE_FILES:=COPYING
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
+PKG_BUILD_FLAGS:=lto
+
include $(INCLUDE_DIR)/package.mk
DISABLE_NLS:=
@@ -60,9 +62,6 @@ ifeq ($(BUILD_VARIANT),json)
CONFIGURE_ARGS += --with-json
endif
-TARGET_CFLAGS += -flto
-TARGET_LDFLAGS += -flto
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/lib $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/