aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/nftables/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/nftables/Makefile')
-rw-r--r--package/network/utils/nftables/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/package/network/utils/nftables/Makefile b/package/network/utils/nftables/Makefile
index 1a082571a0..3b33a1a0a6 100644
--- a/package/network/utils/nftables/Makefile
+++ b/package/network/utils/nftables/Makefile
@@ -7,30 +7,34 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=nftables
-PKG_VERSION:=0.3+2014-09-18
+PKG_VERSION:=0.3+2014-09-30
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=git://git.netfilter.org/nftables
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=013dbc6b0a8490ba24805a8ae35d7707183b9615
+PKG_SOURCE_VERSION:=36c8a131af6217579da582bc320e16171df0f3af
PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
+CONFIGURE_ARGS += \
+ --disable-debug \
+ --without-libgmp \
+ --without-libreadline \
+
define Package/nftables
SECTION:=net
CATEGORY:=Network
SUBMENU:=Firewall
TITLE:=nftables packet filtering userspace utility
- DEPENDS:=+kmod-nft-core +kmod-nft-nat +libnftnl +libgmp
+ DEPENDS:=+kmod-nft-core +kmod-nft-nat +libnftnl
URL:=http://netfilter.org/projects/nftables/
endef
-
define Package/nftables/install
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_BUILD_DIR)/src/nft $(1)/usr/sbin/