aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/linux-atm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/linux-atm/Makefile')
-rw-r--r--package/network/utils/linux-atm/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/network/utils/linux-atm/Makefile b/package/network/utils/linux-atm/Makefile
index d9402c3c16..51e604c0bb 100644
--- a/package/network/utils/linux-atm/Makefile
+++ b/package/network/utils/linux-atm/Makefile
@@ -178,8 +178,9 @@ define Package/atm-diagnostics/install
endef
define Package/br2684ctl/install
- $(INSTALL_DIR) $(1)/etc/init.d/
+ $(INSTALL_DIR) $(1)/etc/init.d $(1)/etc/hotplug.d/atm
$(INSTALL_BIN) ./files/br2684ctl $(1)/etc/init.d/
+ $(INSTALL_DATA) ./files/atm.hotplug $(1)/etc/hotplug.d/atm/00-trigger
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/br2684ctl $(1)/usr/sbin/
endef