aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/iproute2/patches/950-add-cake-to-tc.patch')
-rw-r--r--package/network/utils/iproute2/patches/950-add-cake-to-tc.patch13
1 files changed, 3 insertions, 10 deletions
diff --git a/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch b/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch
index 8da17112be..0705eb12c5 100644
--- a/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch
+++ b/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch
@@ -1,8 +1,6 @@
-diff --git a/include/linux/pkt_sched.h b/include/linux/pkt_sched.h
-index 8d2530d..c55a9a8 100644
--- a/include/linux/pkt_sched.h
+++ b/include/linux/pkt_sched.h
-@@ -850,4 +850,60 @@ struct tc_pie_xstats {
+@@ -863,4 +863,60 @@ struct tc_pie_xstats {
__u32 maxq; /* maximum queue size */
__u32 ecn_mark; /* packets marked with ecn*/
};
@@ -63,21 +61,16 @@ index 8d2530d..c55a9a8 100644
+};
+
#endif
-diff --git a/tc/Makefile b/tc/Makefile
-index 56acbaa..d421b8e 100644
--- a/tc/Makefile
+++ b/tc/Makefile
-@@ -63,6 +63,7 @@ TCMODULES += q_codel.o
+@@ -67,6 +67,7 @@ TCMODULES += q_codel.o
TCMODULES += q_fq_codel.o
TCMODULES += q_fq.o
TCMODULES += q_pie.o
+TCMODULES += q_cake.o
TCMODULES += q_hhf.o
+ TCMODULES += q_clsact.o
TCMODULES += e_bpf.o
-
-diff --git a/tc/q_cake.c b/tc/q_cake.c
-new file mode 100644
-index 0000000..acbe56c
--- /dev/null
+++ b/tc/q_cake.c
@@ -0,0 +1,692 @@