aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iperf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/iperf/Makefile')
-rw-r--r--package/network/utils/iperf/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/network/utils/iperf/Makefile b/package/network/utils/iperf/Makefile
index 6facf7bea7..383eb07949 100644
--- a/package/network/utils/iperf/Makefile
+++ b/package/network/utils/iperf/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=iperf
PKG_VERSION:=2.0.12
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_HASH:=367f651fb1264b13f6518e41b8a7e08ce3e41b2a1c80e99ff0347561eed32646
@@ -40,6 +40,10 @@ endef
TARGET_CFLAGS += -D_GNU_SOURCE
CONFIGURE_ARGS += --disable-multicast
+ifeq ($(CONFIG_IPV6),)
+ CONFIGURE_ARGS += --disable-ipv6
+endif
+
CONFIGURE_VARS += CXXFLAGS="$$$$CXXFLAGS -fno-rtti"
CONFIGURE_VARS += LIBS="-lpthread -lm"