aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/bpftools/patches/001-libbpf-ensure-no-local-symbols-counted-in-ABI-check.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/bpftools/patches/001-libbpf-ensure-no-local-symbols-counted-in-ABI-check.patch')
-rw-r--r--package/network/utils/bpftools/patches/001-libbpf-ensure-no-local-symbols-counted-in-ABI-check.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/package/network/utils/bpftools/patches/001-libbpf-ensure-no-local-symbols-counted-in-ABI-check.patch b/package/network/utils/bpftools/patches/001-libbpf-ensure-no-local-symbols-counted-in-ABI-check.patch
deleted file mode 100644
index 18000b6940..0000000000
--- a/package/network/utils/bpftools/patches/001-libbpf-ensure-no-local-symbols-counted-in-ABI-check.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From fafb2e7eaec6d33ce16e28f481edf781219d5d27 Mon Sep 17 00:00:00 2001
-From: Tony Ambardar <Tony.Ambardar@gmail.com>
-Date: Fri, 24 Jul 2020 23:58:17 -0700
-Subject: [PATCH] tools/libbpf: ensure no local symbols counted in ABI check
-
-This avoids finding versioned local symbols such as _init and _fini in
-the libbpf.so file.
-
-Signed-off-by: Tony Ambardar <Tony.Ambardar@gmail.com>
----
- tools/lib/bpf/Makefile | 2 ++
- 1 file changed, 2 insertions(+)
-
---- a/tools/lib/bpf/Makefile
-+++ b/tools/lib/bpf/Makefile
-@@ -152,6 +152,7 @@ GLOBAL_SYM_COUNT = $(shell readelf -s --
- awk '/GLOBAL/ && /DEFAULT/ && !/UND/ {print $$NF}' | \
- sort -u | wc -l)
- VERSIONED_SYM_COUNT = $(shell readelf --dyn-syms --wide $(OUTPUT)libbpf.so | \
-+ awk '/GLOBAL/ && /DEFAULT/ && !/UND/ {print $$NF}' | \
- grep -Eo '[^ ]+@LIBBPF_' | cut -d@ -f1 | sort -u | wc -l)
-
- CMD_TARGETS = $(LIB_TARGET) $(PC_FILE)
-@@ -219,6 +220,7 @@ check_abi: $(OUTPUT)libbpf.so
- awk '/GLOBAL/ && /DEFAULT/ && !/UND/ {print $$NF}'| \
- sort -u > $(OUTPUT)libbpf_global_syms.tmp; \
- readelf --dyn-syms --wide $(OUTPUT)libbpf.so | \
-+ awk '/GLOBAL/ && /DEFAULT/ && !/UND/ {print $$NF}'| \
- grep -Eo '[^ ]+@LIBBPF_' | cut -d@ -f1 | \
- sort -u > $(OUTPUT)libbpf_versioned_syms.tmp; \
- diff -u $(OUTPUT)libbpf_global_syms.tmp \