aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/uhttpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/services/uhttpd/Makefile')
-rw-r--r--package/network/services/uhttpd/Makefile21
1 files changed, 1 insertions, 20 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index 4090bf4579..3923e55b07 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -20,7 +20,6 @@ PKG_LICENSE:=ISC
PKG_ASLR_PIE_REGULAR:=1
PKG_BUILD_DEPENDS = ustream-ssl
-PKG_CONFIG_DEPENDS:= CONFIG_uhttpd_lua CONFIG_uhttpd_ucode
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
@@ -44,18 +43,6 @@ define Package/uhttpd/description
HTTP daemon.
endef
-define Package/uhttpd/config
- config uhttpd_lua
- depends on PACKAGE_uhttpd-mod-lua
- bool "Enable Integrated Lua interpreter"
- default y
-
- config uhttpd_ucode
- depends on PACKAGE_uhttpd-mod-ucode
- bool "Enable Integrated ucode interpreter"
- default y
-endef
-
define Package/uhttpd/conffiles
/etc/config/uhttpd
/etc/uhttpd.crt
@@ -101,17 +88,11 @@ ifneq ($(CONFIG_USE_GLIBC),)
TARGET_CFLAGS += -D_DEFAULT_SOURCE
endif
-TARGET_LDFLAGS += -lcrypt
-
-CMAKE_OPTIONS += -DTLS_SUPPORT=on
-
define Package/uhttpd/install
- $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_DIR) $(1)/etc/init.d $(1)/etc/config $(1)/usr/sbin
$(INSTALL_BIN) ./files/uhttpd.init $(1)/etc/init.d/uhttpd
- $(INSTALL_DIR) $(1)/etc/config
$(INSTALL_CONF) ./files/uhttpd.config $(1)/etc/config/uhttpd
$(VERSION_SED_SCRIPT) $(1)/etc/config/uhttpd
- $(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/uhttpd $(1)/usr/sbin/uhttpd
endef