aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/samba36
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/services/samba36')
-rw-r--r--package/network/services/samba36/Makefile2
-rwxr-xr-xpackage/network/services/samba36/files/samba.init7
2 files changed, 2 insertions, 7 deletions
diff --git a/package/network/services/samba36/Makefile b/package/network/services/samba36/Makefile
index 0762dd9307..81bad871aa 100644
--- a/package/network/services/samba36/Makefile
+++ b/package/network/services/samba36/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=samba
PKG_VERSION:=3.6.25
-PKG_RELEASE:=7
+PKG_RELEASE:=8
PKG_SOURCE_URL:=https://download.samba.org/pub/samba \
https://download.samba.org/pub/samba/stable
diff --git a/package/network/services/samba36/files/samba.init b/package/network/services/samba36/files/samba.init
index c8413243ba..28b0064df9 100755
--- a/package/network/services/samba36/files/samba.init
+++ b/package/network/services/samba36/files/samba.init
@@ -15,12 +15,7 @@ smb_header() {
for net in $samba_iface; do
local device
network_is_up $net || continue
- network_get_device device "$net" && {
- local subnet
- network_get_subnet subnet "$net" && echo -n "$subnet "
- network_get_subnet6 subnet "$net" && echo -n "$subnet "
- }
-
+ network_get_device device "$net"
echo -n "${device:-$net} "
done
)