aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/services/hostapd')
-rw-r--r--package/network/services/hostapd/Config.in4
-rw-r--r--package/network/services/hostapd/Makefile6
-rw-r--r--package/network/services/hostapd/src/src/utils/build_features.h2
3 files changed, 1 insertions, 11 deletions
diff --git a/package/network/services/hostapd/Config.in b/package/network/services/hostapd/Config.in
index 8aa878d207..5c00f3e24e 100644
--- a/package/network/services/hostapd/Config.in
+++ b/package/network/services/hostapd/Config.in
@@ -79,10 +79,6 @@ config DRIVER_11AX_SUPPORT
bool
default n
-config DRIVER_11W_SUPPORT
- bool
- default n
-
config WPA_ENABLE_WEP
bool "Enable support for unsecure and obsolete WEP"
help
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 45e2e3e337..deb1d565bb 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=19
+PKG_RELEASE:=20
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
@@ -94,10 +94,6 @@ DRIVER_MAKEOPTS= \
CONFIG_IEEE80211AX=$(HOSTAPD_IEEE80211AX) \
CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
-ifneq ($(LOCAL_VARIANT),mini)
- DRIVER_MAKEOPTS += CONFIG_IEEE80211W=$(CONFIG_DRIVER_11W_SUPPORT)
-endif
-
ifeq ($(SSL_VARIANT),openssl)
DRIVER_MAKEOPTS += CONFIG_TLS=openssl CONFIG_SAE=y
TARGET_LDFLAGS += -lcrypto -lssl
diff --git a/package/network/services/hostapd/src/src/utils/build_features.h b/package/network/services/hostapd/src/src/utils/build_features.h
index 7ca65fa391..c7fccad413 100644
--- a/package/network/services/hostapd/src/src/utils/build_features.h
+++ b/package/network/services/hostapd/src/src/utils/build_features.h
@@ -23,10 +23,8 @@ static inline int has_feature(const char *feat)
if (!strcmp(feat, "11r"))
return 1;
#endif
-#ifdef CONFIG_IEEE80211W
if (!strcmp(feat, "11w"))
return 1;
-#endif
#ifdef CONFIG_ACS
if (!strcmp(feat, "acs"))
return 1;