aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/patches/460-disable_ctrl_iface_mib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/services/hostapd/patches/460-disable_ctrl_iface_mib.patch')
-rw-r--r--package/network/services/hostapd/patches/460-disable_ctrl_iface_mib.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/package/network/services/hostapd/patches/460-disable_ctrl_iface_mib.patch b/package/network/services/hostapd/patches/460-disable_ctrl_iface_mib.patch
index f1d9334d5b..e8d8910a41 100644
--- a/package/network/services/hostapd/patches/460-disable_ctrl_iface_mib.patch
+++ b/package/network/services/hostapd/patches/460-disable_ctrl_iface_mib.patch
@@ -43,7 +43,7 @@
reply_len = -1;
--- a/wpa_supplicant/Makefile
+++ b/wpa_supplicant/Makefile
-@@ -754,6 +754,9 @@ ifdef CONFIG_WNM
+@@ -770,6 +770,9 @@ ifdef CONFIG_WNM
OBJS += ../src/ap/wnm_ap.o
endif
ifdef CONFIG_CTRL_IFACE
@@ -55,7 +55,7 @@
--- a/wpa_supplicant/ctrl_iface.c
+++ b/wpa_supplicant/ctrl_iface.c
-@@ -5186,6 +5186,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -5193,6 +5193,7 @@ char * wpa_supplicant_ctrl_iface_process
reply_len = -1;
} else if (os_strncmp(buf, "NOTE ", 5) == 0) {
wpa_printf(MSG_INFO, "NOTE: %s", buf + 5);
@@ -63,7 +63,7 @@
} else if (os_strcmp(buf, "MIB") == 0) {
reply_len = wpa_sm_get_mib(wpa_s->wpa, reply, reply_size);
if (reply_len >= 0) {
-@@ -5197,6 +5198,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -5204,6 +5205,7 @@ char * wpa_supplicant_ctrl_iface_process
else
reply_len += res;
}
@@ -71,7 +71,7 @@
} else if (os_strncmp(buf, "STATUS", 6) == 0) {
reply_len = wpa_supplicant_ctrl_iface_status(
wpa_s, buf + 6, reply, reply_size);
-@@ -5600,6 +5602,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -5607,6 +5609,7 @@ char * wpa_supplicant_ctrl_iface_process
reply_len = wpa_supplicant_ctrl_iface_bss(
wpa_s, buf + 4, reply, reply_size);
#ifdef CONFIG_AP
@@ -79,7 +79,7 @@
} else if (os_strcmp(buf, "STA-FIRST") == 0) {
reply_len = ap_ctrl_iface_sta_first(wpa_s, reply, reply_size);
} else if (os_strncmp(buf, "STA ", 4) == 0) {
-@@ -5608,6 +5611,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -5615,6 +5618,7 @@ char * wpa_supplicant_ctrl_iface_process
} else if (os_strncmp(buf, "STA-NEXT ", 9) == 0) {
reply_len = ap_ctrl_iface_sta_next(wpa_s, buf + 9, reply,
reply_size);
@@ -112,7 +112,7 @@
+
--- a/src/ap/ieee802_1x.c
+++ b/src/ap/ieee802_1x.c
-@@ -2042,6 +2042,7 @@ static const char * bool_txt(Boolean boo
+@@ -1939,6 +1939,7 @@ static const char * bool_txt(Boolean boo
return bool ? "TRUE" : "FALSE";
}
@@ -120,7 +120,7 @@
int ieee802_1x_get_mib(struct hostapd_data *hapd, char *buf, size_t buflen)
{
-@@ -2194,6 +2195,7 @@ int ieee802_1x_get_mib_sta(struct hostap
+@@ -2091,6 +2092,7 @@ int ieee802_1x_get_mib_sta(struct hostap
return len;
}