aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/ipv6')
-rw-r--r--package/network/ipv6/6in4/Makefile2
-rw-r--r--package/network/ipv6/6rd/Makefile2
-rw-r--r--package/network/ipv6/6to4/Makefile2
-rw-r--r--package/network/ipv6/ds-lite/Makefile2
-rw-r--r--package/network/ipv6/map/Makefile2
-rw-r--r--package/network/ipv6/odhcp6c/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index b7c2da725c..2ffdfc0e95 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/6in4
SECTION:=net
CATEGORY:=Network
- DEPENDS:=+kmod-ipv6 +kmod-sit
+ DEPENDS:=@IPV6 +kmod-sit
TITLE:=IPv6-in-IPv4 configuration support
MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
PKGARCH:=all
diff --git a/package/network/ipv6/6rd/Makefile b/package/network/ipv6/6rd/Makefile
index cde711771c..04d607eb9e 100644
--- a/package/network/ipv6/6rd/Makefile
+++ b/package/network/ipv6/6rd/Makefile
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/6rd
SECTION:=net
CATEGORY:=Network
- DEPENDS:=+kmod-ipv6 +kmod-sit
+ DEPENDS:=@IPV6 +kmod-sit
TITLE:=6rd configuration support
MAINTAINER:=Steven Barth <cyrus@openwrt.org>
PKGARCH:=all
diff --git a/package/network/ipv6/6to4/Makefile b/package/network/ipv6/6to4/Makefile
index fcec90de0b..20605f6588 100644
--- a/package/network/ipv6/6to4/Makefile
+++ b/package/network/ipv6/6to4/Makefile
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/6to4
SECTION:=net
CATEGORY:=Network
- DEPENDS:=+kmod-ipv6 +kmod-sit
+ DEPENDS:=@IPV6 +kmod-sit
TITLE:=IPv6-to-IPv4 configuration support
MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
PKGARCH:=all
diff --git a/package/network/ipv6/ds-lite/Makefile b/package/network/ipv6/ds-lite/Makefile
index 8c22c46a15..919ac7e74d 100644
--- a/package/network/ipv6/ds-lite/Makefile
+++ b/package/network/ipv6/ds-lite/Makefile
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/ds-lite
SECTION:=net
CATEGORY:=Network
- DEPENDS:=+kmod-ipv6 +kmod-ip6-tunnel +resolveip
+ DEPENDS:=@IPV6 +kmod-ip6-tunnel +resolveip
TITLE:=Dual-Stack Lite (DS-Lite) configuration support
MAINTAINER:=Steven Barth <steven@midlink.org>
PKGARCH:=all
diff --git a/package/network/ipv6/map/Makefile b/package/network/ipv6/map/Makefile
index f6f2cd6fde..af6f75874f 100644
--- a/package/network/ipv6/map/Makefile
+++ b/package/network/ipv6/map/Makefile
@@ -18,7 +18,7 @@ include $(INCLUDE_DIR)/cmake.mk
define Package/map
SECTION:=net
CATEGORY:=Network
- DEPENDS:=+kmod-ipv6 +kmod-ip6-tunnel +libubox +libubus +iptables-mod-conntrack-extra
+ DEPENDS:=@IPV6 +kmod-ip6-tunnel +libubox +libubus +iptables-mod-conntrack-extra
TITLE:=MAP-E and Lightweight 4over6 configuration support
MAINTAINER:=Steven Barth <steven@midlink.org>
endef
diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index 7c88d59f5c..0b38be93cd 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -30,7 +30,7 @@ define Package/odhcp6c
SECTION:=net
CATEGORY:=Network
TITLE:=Embedded DHCPv6-client for OpenWrt
- DEPENDS:=+kmod-ipv6
+ DEPENDS:=@IPV6
endef
define Package/odhcp6c/config