aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/config')
-rw-r--r--package/network/config/firewall/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/network/config/firewall/Makefile b/package/network/config/firewall/Makefile
index e4a3ad97f7..95e2ae4b67 100644
--- a/package/network/config/firewall/Makefile
+++ b/package/network/config/firewall/Makefile
@@ -21,6 +21,8 @@ PKG_LICENSE:=ISC
PKG_CONFIG_DEPENDS := CONFIG_IPV6
+PKG_BUILD_FLAGS:=gc-sections
+
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
@@ -42,8 +44,8 @@ define Package/firewall/conffiles
/etc/firewall.user
endef
-TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
-TARGET_LDFLAGS += -Wl,--gc-sections -flto
+TARGET_CFLAGS += -flto
+TARGET_LDFLAGS += -flto
CMAKE_OPTIONS += $(if $(CONFIG_IPV6),,-DDISABLE_IPV6=1)
define Package/firewall/install