aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/vti
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/config/vti')
-rw-r--r--package/network/config/vti/Makefile2
-rwxr-xr-xpackage/network/config/vti/files/vti.sh7
2 files changed, 7 insertions, 2 deletions
diff --git a/package/network/config/vti/Makefile b/package/network/config/vti/Makefile
index bda2a9ab17..0a4657c94e 100644
--- a/package/network/config/vti/Makefile
+++ b/package/network/config/vti/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=vti
PKG_VERSION:=1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/config/vti/files/vti.sh b/package/network/config/vti/files/vti.sh
index 763fd4ee32..0443800a0c 100755
--- a/package/network/config/vti/files/vti.sh
+++ b/package/network/config/vti/files/vti.sh
@@ -26,7 +26,12 @@ vti_generic_setup() {
json_add_string local "$local"
json_add_string remote "$remote"
[ -n "$tunlink" ] && json_add_string link "$tunlink"
- json_add_string info "${ikey:-0},${okey:-0}"
+
+ json_add_object 'data'
+ [ -n "$ikey" ] && json_add_int ikey "$ikey"
+ [ -n "$okey" ] && json_add_int okey "$okey"
+ json_close_object
+
proto_close_tunnel
proto_add_data