aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/gre/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/config/gre/Makefile')
-rw-r--r--package/network/config/gre/Makefile39
1 files changed, 5 insertions, 34 deletions
diff --git a/package/network/config/gre/Makefile b/package/network/config/gre/Makefile
index b191327f87..73319e80cf 100644
--- a/package/network/config/gre/Makefile
+++ b/package/network/config/gre/Makefile
@@ -15,40 +15,21 @@ PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
define Package/gre/Default
- SECTION:=net
- CATEGORY:=Network
- MAINTAINER:=Hans Dedecker <dedeckeh@gmail.com>
endef
define Package/gre
-$(call Package/gre/Default)
+ SECTION:=net
+ CATEGORY:=Network
+ MAINTAINER:=Hans Dedecker <dedeckeh@gmail.com>
TITLE:=Generic Routing Encapsulation config support
+ DEPENDS:=+kmod-gre +IPV6:kmod-gre6 +resolveip
+ PROVIDES:=grev4 grev6
endef
define Package/gre/description
Generic Routing Encapsulation config support (IPv4 and IPv6) in /etc/config/network.
endef
-define Package/grev4
-$(call Package/gre/Default)
- TITLE:=Generic Routing Encapsulation (IPv4) config support
- DEPENDS:=@(PACKAGE_gre) +kmod-gre +resolveip
-endef
-
-define Package/grev4/description
- Generic Routing Encapsulation config support (IPv4) in /etc/config/network.
-endef
-
-define Package/grev6
-$(call Package/gre/Default)
- TITLE:=Generic Routing Encapsulation (IPv6) config support
- DEPENDS:=@(PACKAGE_gre) @IPV6 +kmod-gre6 +resolveip
-endef
-
-define Package/grev6/description
- Generic Routing Encapsulation config support (IPv6) in /etc/config/network.
-endef
-
define Build/Compile
endef
@@ -60,14 +41,4 @@ define Package/gre/install
$(INSTALL_BIN) ./files/gre.sh $(1)/lib/netifd/proto/gre.sh
endef
-define Package/grev4/install
- :
-endef
-
-define Package/grev6/install
- :
-endef
-
$(eval $(call BuildPackage,gre))
-$(eval $(call BuildPackage,grev4))
-$(eval $(call BuildPackage,grev6))