aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/patches/320-enable_rt2800.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/mac80211/patches/320-enable_rt2800.patch')
-rw-r--r--package/mac80211/patches/320-enable_rt2800.patch15
1 files changed, 12 insertions, 3 deletions
diff --git a/package/mac80211/patches/320-enable_rt2800.patch b/package/mac80211/patches/320-enable_rt2800.patch
index 4b406de3b7..818063948f 100644
--- a/package/mac80211/patches/320-enable_rt2800.patch
+++ b/package/mac80211/patches/320-enable_rt2800.patch
@@ -1,15 +1,14 @@
--- a/config.mk
+++ b/config.mk
-@@ -156,6 +156,8 @@ CONFIG_ADM8211=m
+@@ -156,6 +156,7 @@ CONFIG_ADM8211=m
CONFIG_RT2X00_LIB_PCI=m
CONFIG_RT2400PCI=m
CONFIG_RT2500PCI=m
+CONFIG_RT2800PCI=m
-+CONFIG_RT2800USB=m
NEED_RT2X00=y
# Two rt2x00 drivers require firmware: rt61pci and rt73usb. They depend on
-@@ -197,6 +199,8 @@ CONFIG_RTL8187=m
+@@ -197,6 +198,8 @@ CONFIG_RTL8187=m
# RT2500USB does not require firmware
CONFIG_RT2500USB=m
CONFIG_RT2X00_LIB_USB=m
@@ -18,3 +17,13 @@
NEED_RT2X00=y
# RT73USB requires firmware
ifneq ($(CONFIG_CRC_ITU_T),)
+@@ -204,6 +207,9 @@ CONFIG_RT73USB=m
+ NEED_RT2X00_FIRMWARE=y
+ endif
+
++# RT2800USB support
++CONFIG_RT2800USB=m
++
+ endif # end of USB driver list
+
+ # Common rt2x00 requirements