aboutsummaryrefslogtreecommitdiffstats
path: root/package/lua/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/lua/Makefile')
-rw-r--r--package/lua/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/lua/Makefile b/package/lua/Makefile
index aff52c3f24..eff31390af 100644
--- a/package/lua/Makefile
+++ b/package/lua/Makefile
@@ -86,6 +86,12 @@ endef
TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC)
+ifneq ($(CONFIG_USE_EGLIBC),)
+ ifeq ($(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),)
+ TARGET_CFLAGS += -DNO_GETLOGIN
+ endif
+endif
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CROSS)gcc" \