aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/elfutils/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index 9aa78d8352..07b3ea66c6 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -24,6 +24,8 @@ PKG_INSTALL:=1
PKG_USE_MIPS16:=1
PKG_BUILD_DEPENDS:=!USE_GLIBC:argp-standalone
+HOST_BUILD_DEPENDS:=argp-standalone/host musl-fts/host
+
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
include $(INCLUDE_DIR)/host-build.mk
@@ -62,6 +64,8 @@ CONFIGURE_ARGS += --disable-nls
endif
HOST_CONFIGURE_ARGS += \
+ --disable-shared \
+ --disable-nls \
--disable-debuginfod \
--disable-libdebuginfod \
--without-lzma \