aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/libubox/Makefile2
-rw-r--r--package/libs/mbedtls/Makefile2
-rw-r--r--package/libs/ncurses/Makefile2
-rw-r--r--package/libs/openssl/Makefile2
-rw-r--r--package/libs/readline/Makefile2
-rw-r--r--package/libs/ustream-ssl/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/package/libs/libubox/Makefile b/package/libs/libubox/Makefile
index a0e75f936c..8267486d72 100644
--- a/package/libs/libubox/Makefile
+++ b/package/libs/libubox/Makefile
@@ -27,7 +27,7 @@ define Package/libubox
SECTION:=libs
CATEGORY:=Libraries
TITLE:=Basic utility library
- ABI_VERSION:=$(PKG_VERSION)
+ ABI_VERSION:=20170601
DEPENDS:=
endef
diff --git a/package/libs/mbedtls/Makefile b/package/libs/mbedtls/Makefile
index e265cac575..ce513e59b0 100644
--- a/package/libs/mbedtls/Makefile
+++ b/package/libs/mbedtls/Makefile
@@ -39,7 +39,7 @@ $(call Package/mbedtls/Default)
CATEGORY:=Libraries
SUBMENU:=SSL
TITLE+= (library)
- ABI_VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)
+ ABI_VERSION:=12
endef
define Package/mbedtls-util
diff --git a/package/libs/ncurses/Makefile b/package/libs/ncurses/Makefile
index 904d3c1551..5be65c2f08 100644
--- a/package/libs/ncurses/Makefile
+++ b/package/libs/ncurses/Makefile
@@ -41,7 +41,7 @@ define Package/libncurses
URL:=http://www.gnu.org/software/ncurses/
PROVIDES:=libncursesw
DEPENDS:= +terminfo
- ABI_VERSION:=$(PKG_VERSION)
+ ABI_VERSION:=6
endef
define Package/libncurses-dev
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 1e28267560..35759566f9 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -74,7 +74,7 @@ $(call Package/openssl/Default)
CATEGORY:=Libraries
DEPENDS:=+OPENSSL_WITH_COMPRESSION:zlib
TITLE+= (libraries)
- ABI_VERSION:=$(PKG_VERSION)
+ ABI_VERSION:=1.0.0
MENU:=1
endef
diff --git a/package/libs/readline/Makefile b/package/libs/readline/Makefile
index ca3a468637..246e318750 100644
--- a/package/libs/readline/Makefile
+++ b/package/libs/readline/Makefile
@@ -31,7 +31,7 @@ define Package/libreadline
CATEGORY:=Libraries
TITLE:=Command lines edition library
URL:=http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html
- ABI_VERSION:=$(PKG_VERSION)
+ ABI_VERSION:=7
endef
define Package/libreadline/description
diff --git a/package/libs/ustream-ssl/Makefile b/package/libs/ustream-ssl/Makefile
index 2ea5bf0bd5..a15f3d8ab8 100644
--- a/package/libs/ustream-ssl/Makefile
+++ b/package/libs/ustream-ssl/Makefile
@@ -25,7 +25,7 @@ define Package/libustream/default
CATEGORY:=Libraries
TITLE:=ustream SSL Library
DEPENDS:=+libubox
- ABI_VERSION:=$(PKG_VERSION)
+ ABI_VERSION:=20150806
endef
define Package/libustream-openssl