aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/wolfssl/patches/001-fix-detection-of-cut-tool-in-configure.ac.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/wolfssl/patches/001-fix-detection-of-cut-tool-in-configure.ac.patch')
-rw-r--r--package/libs/wolfssl/patches/001-fix-detection-of-cut-tool-in-configure.ac.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/package/libs/wolfssl/patches/001-fix-detection-of-cut-tool-in-configure.ac.patch b/package/libs/wolfssl/patches/001-fix-detection-of-cut-tool-in-configure.ac.patch
new file mode 100644
index 0000000000..0d0c8b5423
--- /dev/null
+++ b/package/libs/wolfssl/patches/001-fix-detection-of-cut-tool-in-configure.ac.patch
@@ -0,0 +1,25 @@
+From 41d248461bd9ad44193a4806ecb5361513e8944e Mon Sep 17 00:00:00 2001
+From: jordan <jordan@wolfssl.com>
+Date: Tue, 27 Jun 2023 13:18:25 -0500
+Subject: [PATCH] fix detection of cut tool in configure.ac
+
+---
+ configure.ac | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -8723,10 +8723,11 @@ echo "extern \"C\" {" >> $OPTION_FILE
+ echo "#endif" >> $OPTION_FILE
+ echo "" >> $OPTION_FILE
+
+-# check for supported command to trim option with
++# Check for supported command to trim option with.
++# note: cut requires an argument to exit with success.
+ if colrm >/dev/null 2>&1 </dev/null; then
+ TRIM="colrm 3"
+-elif cut >/dev/null 2>&1 </dev/null; then
++elif cut --version >/dev/null 2>&1 </dev/null; then
+ TRIM="cut -c1-2"
+ else
+ AC_MSG_ERROR([Could not find colrm or cut to make options file])