aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/openssl/patches/200-parallel_build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/openssl/patches/200-parallel_build.patch')
-rw-r--r--package/libs/openssl/patches/200-parallel_build.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/package/libs/openssl/patches/200-parallel_build.patch b/package/libs/openssl/patches/200-parallel_build.patch
index c2eeb387f5..ff63e02982 100644
--- a/package/libs/openssl/patches/200-parallel_build.patch
+++ b/package/libs/openssl/patches/200-parallel_build.patch
@@ -1,7 +1,7 @@
--- a/Makefile.org
+++ b/Makefile.org
-@@ -274,17 +274,17 @@ build_all: build_libs build_apps build_t
- build_libs: build_crypto build_ssl build_engines
+@@ -277,17 +277,17 @@ build_libcrypto: build_crypto build_engi
+ build_libssl: build_ssl libssl.pc
build_crypto:
- @dir=crypto; target=all; $(BUILD_ONE_CMD)
@@ -29,8 +29,8 @@
all_testapps: build_libs build_testapps
build_testapps:
-@@ -453,7 +453,7 @@ report:
- @$(PERL) util/selftest.pl
+@@ -459,7 +459,7 @@ update: errors stacks util/libeay.num ut
+ @set -e; target=update; $(RECURSIVE_BUILD_CMD)
depend:
- @set -e; target=depend; $(RECURSIVE_BUILD_CMD)
@@ -38,7 +38,7 @@
lint:
@set -e; target=lint; $(RECURSIVE_BUILD_CMD)
-@@ -531,9 +531,9 @@ dist:
+@@ -521,9 +521,9 @@ dist:
dist_pem_h:
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
@@ -50,7 +50,7 @@
@$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
$(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR) \
$(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines \
-@@ -542,12 +542,19 @@ install_sw:
+@@ -532,12 +532,19 @@ install_sw:
$(INSTALL_PREFIX)$(OPENSSLDIR)/misc \
$(INSTALL_PREFIX)$(OPENSSLDIR)/certs \
$(INSTALL_PREFIX)$(OPENSSLDIR)/private
@@ -71,7 +71,7 @@
@set -e; liblist="$(LIBS)"; for i in $$liblist ;\
do \
if [ -f "$$i" ]; then \
-@@ -631,12 +638,7 @@ install_html_docs:
+@@ -621,12 +628,7 @@ install_html_docs:
done; \
done
@@ -178,7 +178,7 @@
apps:
@(cd ..; $(MAKE) DIRS=apps all)
-@@ -529,7 +529,7 @@ $(CONSTTIMETEST)$(EXE_EXT): $(CONSTTIMET
+@@ -530,7 +530,7 @@ $(CONSTTIMETEST)$(EXE_EXT): $(CONSTTIMET
# fi
dummytest$(EXE_EXT): dummytest.o $(DLIBCRYPTO)