aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/ncurses
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/ncurses')
-rw-r--r--package/libs/ncurses/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/ncurses/Makefile b/package/libs/ncurses/Makefile
index 26b7bf59db..b8088b9622 100644
--- a/package/libs/ncurses/Makefile
+++ b/package/libs/ncurses/Makefile
@@ -16,7 +16,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/ncurses
PKG_MD5SUM:=8cb9c412e5f2d96bc6f459aa8c6282a1
-PKG_LICENSE:=FREE
+PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=README
PKG_INSTALL:=1
a id='n111' href='#n111'>111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211
#ifndef _XEN_IA64_VCPU_H
#define _XEN_IA64_VCPU_H

// TODO: Many (or perhaps most) of these should eventually be
// static inline functions

#include <asm/delay.h>
#include <asm/fpu.h>
#include <asm/tlb.h>
#include <asm/ia64_int.h>
#include <xen/types.h>
#include <public/xen.h>
#include <linux/acpi.h>
struct vcpu;
typedef struct vcpu VCPU;
typedef cpu_user_regs_t REGS;
extern u64 cycle_to_ns(u64 cycle);

/* Note: PSCB stands for Privilegied State Communication Block.  */
#define VCPU(_v,_x)	(_v->arch.privregs->_x)
#define PSCB(_v,_x)	VCPU(_v,_x)
#define PSCBX(_v,_x)	(_v->arch._x)

#define SPURIOUS_VECTOR 0xf

/* general registers */
extern u64 vcpu_get_gr(VCPU * vcpu, unsigned long reg);
extern IA64FAULT vcpu_get_gr_nat(VCPU * vcpu, unsigned long reg, u64 * val);
extern IA64FAULT vcpu_set_gr(VCPU * vcpu, unsigned long reg, u64 value,
                             int nat);
extern IA64FAULT vcpu_get_fpreg(VCPU * vcpu, unsigned long reg,
                                struct ia64_fpreg *val);

extern IA64FAULT vcpu_set_fpreg(VCPU * vcpu, unsigned long reg,
                                struct ia64_fpreg *val);

/* application registers */
extern void vcpu_load_kernel_regs(VCPU * vcpu);
extern IA64FAULT vcpu_set_ar(VCPU * vcpu, u64 reg, u64 val);
extern IA64FAULT vcpu_get_ar(VCPU * vcpu, u64 reg, u64 * val);
/* psr */
extern BOOLEAN vcpu_get_psr_ic(VCPU * vcpu);
extern u64 vcpu_get_ipsr_int_state(VCPU * vcpu, u64 prevpsr);
extern IA64FAULT vcpu_get_psr(VCPU * vcpu, u64 * pval);
extern IA64FAULT vcpu_reset_psr_sm(VCPU * vcpu, u64 imm);
extern IA64FAULT vcpu_set_psr_sm(VCPU * vcpu, u64 imm);
extern IA64FAULT vcpu_set_psr_l(VCPU * vcpu, u64 val);
extern IA64FAULT vcpu_set_psr_i(VCPU * vcpu);
extern IA64FAULT vcpu_reset_psr_dt(VCPU * vcpu);
extern IA64FAULT vcpu_set_psr_dt(VCPU * vcpu);
/* control registers */
extern IA64FAULT vcpu_set_dcr(VCPU * vcpu, u64 val);
extern IA64FAULT vcpu_set_itm(VCPU * vcpu, u64 val);
extern IA64FAULT vcpu_set_iva(VCPU * vcpu, u64 val);
extern IA64FAULT vcpu_set_pta(VCPU * vcpu, u64 val);
extern IA64FAULT vcpu_set_ipsr(VCPU * vcpu, u64 val);
extern IA64FAULT vcpu_set_isr(VCPU * vcpu, u64 val);
extern IA64FAULT vcpu_set_iip(VCPU * vcpu, u64 val);
extern IA64FAULT vcpu_set_ifa(VCPU * vcpu, u64 val);
extern IA64FAULT vcpu_set_itir(VCPU * vcpu, u64 val);
extern IA64FAULT vcpu_set_iipa(VCPU * vcpu, u64 val);
extern IA64FAULT vcpu_set_ifs(VCPU * vcpu, u64 val);
extern IA64FAULT vcpu_set_iim(VCPU * vcpu, u64 val);