aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libxml2/patches/010-iconv.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/libxml2/patches/010-iconv.patch')
-rw-r--r--package/libs/libxml2/patches/010-iconv.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/libs/libxml2/patches/010-iconv.patch b/package/libs/libxml2/patches/010-iconv.patch
new file mode 100644
index 0000000000..e35b7ce939
--- /dev/null
+++ b/package/libs/libxml2/patches/010-iconv.patch
@@ -0,0 +1,12 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -496,6 +496,9 @@ if(LIBXML2_WITH_PROGRAMS)
+ add_executable(LibXml2::${PROGRAM} ALIAS ${PROGRAM})
+ target_compile_definitions(${PROGRAM} PRIVATE SYSCONFDIR="${CMAKE_INSTALL_FULL_SYSCONFDIR}")
+ target_link_libraries(${PROGRAM} LibXml2)
++ if(LIBXML2_WITH_ICONV AND NOT Iconv_IS_BUILT_IN)
++ target_link_libraries(${PROGRAM} iconv)
++ endif()
+ if(HAVE_LIBHISTORY)
+ target_link_libraries(${PROGRAM} history)
+ endif()