aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libtool
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/libtool')
-rw-r--r--package/libs/libtool/Makefile52
-rw-r--r--package/libs/libtool/patches/160-passthrough-ssp.patch11
2 files changed, 0 insertions, 63 deletions
diff --git a/package/libs/libtool/Makefile b/package/libs/libtool/Makefile
deleted file mode 100644
index 8091081f96..0000000000
--- a/package/libs/libtool/Makefile
+++ /dev/null
@@ -1,52 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libtool
-PKG_VERSION:=2.4
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@GNU/libtool
-PKG_MD5SUM:=b32b04148ecdd7344abc6fe8bd1bb021
-
-PKG_LICENSE:=GPL-2.0+
-PKG_LICENSE_FILES:=COPYING
-
-PKG_BUILD_PARALLEL:=0
-
-include $(INCLUDE_DIR)/package.mk
-
-CONFIGURE_PREFIX=$(STAGING_DIR)/host
-export GLOBAL_LIBDIR=$(STAGING_DIR)/usr/lib
-
-define Package/libltdl
- SECTION:=libs
- CATEGORY:=Libraries
- TITLE:=A generic dynamic object loading library
- URL:=http://www.gnu.org/software/libtool/
-endef
-
-define Build/InstallDev
- $(MAKE) -C $(PKG_BUILD_DIR) \
- bindir="$(2)/bin" \
- datadir="$(2)/share" \
- prefix="$(2)" \
- exec_prefix="$(2)" \
- install
- $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/include
- mv $(2)/lib/* $(1)/usr/lib/
- mv $(2)/include/* $(1)/usr/include/
-endef
-
-define Package/libltdl/install
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/libltdl/.libs/libltdl.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libltdl))
diff --git a/package/libs/libtool/patches/160-passthrough-ssp.patch b/package/libs/libtool/patches/160-passthrough-ssp.patch
deleted file mode 100644
index 6fcbe68000..0000000000
--- a/package/libs/libtool/patches/160-passthrough-ssp.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/libltdl/config/ltmain.m4sh
-+++ b/libltdl/config/ltmain.m4sh
-@@ -5051,7 +5051,7 @@ func_mode_link ()
- # -O*, -flto*, -fwhopr*, -fuse-linker-plugin GCC link-time optimization
- -64|-mips[0-9]|-r[0-9][0-9]*|-xarch=*|-xtarget=*|+DA*|+DD*|-q*|-m*| \
- -t[45]*|-txscale*|-p|-pg|--coverage|-fprofile-*|-F*|@*|-tp=*|--sysroot=*| \
-- -O*|-flto*|-fwhopr*|-fuse-linker-plugin)
-+ -O*|-flto*|-fwhopr*|-fuse-linker-plugin|-fstack-protector*)
- func_quote_for_eval "$arg"
- arg="$func_quote_for_eval_result"
- func_append compile_command " $arg"