aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libpcap
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/libpcap')
-rw-r--r--package/libs/libpcap/Makefile21
1 files changed, 20 insertions, 1 deletions
diff --git a/package/libs/libpcap/Makefile b/package/libs/libpcap/Makefile
index 35ceb18c29..8586300d75 100644
--- a/package/libs/libpcap/Makefile
+++ b/package/libs/libpcap/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libpcap
PKG_VERSION:=1.9.1
-PKG_RELEASE:=3
+PKG_RELEASE:=3.1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.us.tcpdump.org/release/ \
@@ -45,6 +45,19 @@ define Package/libpcap/config
source "$(SOURCE)/Config.in"
endef
+define Package/rpcapd
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Capture daemon to be controlled by a remote libpcap application
+ URL:=http://www.tcpdump.org/
+ DEPENDS+= +libpcap
+endef
+
+ifdef CONFIG_PACKAGE_rpcapd
+ CMAKE_OPTIONS += \
+ -DENABLE_REMOTE=ON
+endif
+
CMAKE_OPTIONS += \
-DBUILD_SHARED_LIBS=ON \
-DBUILD_WITH_LIBNL=OFF \
@@ -84,4 +97,10 @@ define Package/libpcap/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcap.so.* $(1)/usr/lib/
endef
+define Package/rpcapd/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/rpcapd $(1)/usr/bin/
+endef
+
$(eval $(call BuildPackage,libpcap))
+$(eval $(call BuildPackage,rpcapd))