aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libcxx/patches
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/libcxx/patches')
-rw-r--r--package/libs/libcxx/patches/010-cxx17.patch2
-rw-r--r--package/libs/libcxx/patches/020-fixes.patch13
2 files changed, 13 insertions, 2 deletions
diff --git a/package/libs/libcxx/patches/010-cxx17.patch b/package/libs/libcxx/patches/010-cxx17.patch
index c313c47611..dceec9d4f3 100644
--- a/package/libs/libcxx/patches/010-cxx17.patch
+++ b/package/libs/libcxx/patches/010-cxx17.patch
@@ -1,6 +1,6 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -524,9 +524,9 @@ remove_flags(-Wno-pedantic -pedantic-errors -pedantic)
+@@ -524,9 +524,9 @@ remove_flags(-Wno-pedantic -pedantic-err
if (LIBCXX_HAS_MUSL_LIBC OR LIBCXX_TARGETING_CLANG_CL)
# musl's pthread implementations uses volatile types in their structs which is
# not a constexpr in C++11 but is in C++14, so we use C++14 with musl.
diff --git a/package/libs/libcxx/patches/020-fixes.patch b/package/libs/libcxx/patches/020-fixes.patch
index abc630d42f..22ac494c04 100644
--- a/package/libs/libcxx/patches/020-fixes.patch
+++ b/package/libs/libcxx/patches/020-fixes.patch
@@ -1,6 +1,17 @@
+--- a/include/cmath
++++ b/include/cmath
+@@ -615,7 +615,7 @@ _Fp __lerp(_Fp __a, _Fp __b, _Fp __t) no
+
+ if (__t == 1) return __b;
+ const _Fp __x = __a + __t * (__b - __a);
+- if (__t > 1 == __b > __a)
++ if ((__t > 1) == (__b > __a))
+ return __b < __x ? __x : __b;
+ else
+ return __x < __b ? __x : __b;
--- a/include/memory
+++ b/include/memory
-@@ -1696,7 +1696,7 @@ struct _LIBCPP_TEMPLATE_VIS allocator_traits
+@@ -1696,7 +1696,7 @@ struct _LIBCPP_TEMPLATE_VIS allocator_tr
ptrdiff_t _Np = __end1 - __begin1;
__end2 -= _Np;
if (_Np > 0)