aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libcxx/patches/010-cxx17.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/libcxx/patches/010-cxx17.patch')
-rw-r--r--package/libs/libcxx/patches/010-cxx17.patch14
1 files changed, 0 insertions, 14 deletions
diff --git a/package/libs/libcxx/patches/010-cxx17.patch b/package/libs/libcxx/patches/010-cxx17.patch
deleted file mode 100644
index dceec9d4f3..0000000000
--- a/package/libs/libcxx/patches/010-cxx17.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -524,9 +524,9 @@ remove_flags(-Wno-pedantic -pedantic-err
- if (LIBCXX_HAS_MUSL_LIBC OR LIBCXX_TARGETING_CLANG_CL)
- # musl's pthread implementations uses volatile types in their structs which is
- # not a constexpr in C++11 but is in C++14, so we use C++14 with musl.
-- set(LIBCXX_STANDARD_VER c++14 CACHE STRING "internal option to change build dialect")
-+ set(LIBCXX_STANDARD_VER c++2a CACHE STRING "internal option to change build dialect")
- else()
-- set(LIBCXX_STANDARD_VER c++11 CACHE STRING "internal option to change build dialect")
-+ set(LIBCXX_STANDARD_VER c++2a CACHE STRING "internal option to change build dialect")
- endif()
- add_compile_flags_if_supported(-std=${LIBCXX_STANDARD_VER})
- add_compile_flags_if_supported("/std:${LIBCXX_STANDARD_VER}")