aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils/patches/101-no-fts.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/elfutils/patches/101-no-fts.patch')
-rw-r--r--package/libs/elfutils/patches/101-no-fts.patch64
1 files changed, 17 insertions, 47 deletions
diff --git a/package/libs/elfutils/patches/101-no-fts.patch b/package/libs/elfutils/patches/101-no-fts.patch
index 63699fea26..a6e192f8ff 100644
--- a/package/libs/elfutils/patches/101-no-fts.patch
+++ b/package/libs/elfutils/patches/101-no-fts.patch
@@ -1,7 +1,5 @@
-Index: elfutils-0.169/libdwfl/argp-std.c
-===================================================================
---- elfutils-0.169.orig/libdwfl/argp-std.c
-+++ elfutils-0.169/libdwfl/argp-std.c
+--- a/libdwfl/argp-std.c
++++ b/libdwfl/argp-std.c
@@ -56,9 +56,6 @@ static const struct argp_option options[
{ "linux-process-map", 'M', "FILE", 0,
N_("Find addresses in files mapped as read from FILE"
@@ -28,7 +26,7 @@ Index: elfutils-0.169/libdwfl/argp-std.c
/* Structure held at state->HOOK. */
struct parse_opt
{
-@@ -223,43 +211,6 @@ parse_opt (int key, char *arg, struct ar
+@@ -226,43 +214,6 @@ parse_opt (int key, char *arg, struct ar
}
break;
@@ -40,11 +38,11 @@ Index: elfutils-0.169/libdwfl/argp-std.c
- Dwfl *dwfl = INTUSE(dwfl_begin) (&kernel_callbacks);
- int result = INTUSE(dwfl_linux_kernel_report_kernel) (dwfl);
- if (result != 0)
-- return fail (dwfl, result, _("cannot load kernel symbols"));
+- return fail (dwfl, result, _("cannot load kernel symbols"), state);
- result = INTUSE(dwfl_linux_kernel_report_modules) (dwfl);
- if (result != 0)
- /* Non-fatal to have no modules since we do have the kernel. */
-- failure (dwfl, result, _("cannot find kernel modules"));
+- argp_failure (state, 0, result, _("cannot find kernel modules"));
- opt->dwfl = dwfl;
- }
- else
@@ -61,7 +59,7 @@ Index: elfutils-0.169/libdwfl/argp-std.c
- int result = INTUSE(dwfl_linux_kernel_report_offline) (dwfl, arg,
- NULL);
- if (result != 0)
-- return fail (dwfl, result, _("cannot find kernel or modules"));
+- return fail (dwfl, result, _("cannot find kernel or modules"), state);
- opt->dwfl = dwfl;
- }
- else
@@ -72,42 +70,14 @@ Index: elfutils-0.169/libdwfl/argp-std.c
case ARGP_KEY_SUCCESS:
{
struct parse_opt *opt = state->hook;
-Index: elfutils-0.169/libdwfl/Makefile.in
-===================================================================
---- elfutils-0.169.orig/libdwfl/Makefile.in
-+++ elfutils-0.169/libdwfl/Makefile.in
-@@ -120,7 +120,7 @@ am__libdwfl_a_SOURCES_DIST = dwfl_begin.
- dwfl_getmodules.c dwfl_getdwarf.c dwfl_module_getdwarf.c \
- dwfl_module_getelf.c dwfl_validate_address.c argp-std.c \
- find-debuginfo.c dwfl_build_id_find_elf.c \
-- dwfl_build_id_find_debuginfo.c linux-kernel-modules.c \
-+ dwfl_build_id_find_debuginfo.c \
- linux-proc-maps.c dwfl_addrmodule.c dwfl_addrdwarf.c cu.c \
- dwfl_module_nextcu.c dwfl_nextcu.c dwfl_cumodule.c \
- dwfl_module_addrdie.c dwfl_addrdie.c lines.c dwfl_lineinfo.c \
-@@ -148,7 +148,7 @@ am_libdwfl_a_OBJECTS = dwfl_begin.$(OBJE
- dwfl_validate_address.$(OBJEXT) argp-std.$(OBJEXT) \
- find-debuginfo.$(OBJEXT) dwfl_build_id_find_elf.$(OBJEXT) \
- dwfl_build_id_find_debuginfo.$(OBJEXT) \
-- linux-kernel-modules.$(OBJEXT) linux-proc-maps.$(OBJEXT) \
-+ linux-proc-maps.$(OBJEXT) \
- dwfl_addrmodule.$(OBJEXT) dwfl_addrdwarf.$(OBJEXT) \
- cu.$(OBJEXT) dwfl_module_nextcu.$(OBJEXT) \
- dwfl_nextcu.$(OBJEXT) dwfl_cumodule.$(OBJEXT) \
-@@ -434,7 +434,7 @@ libdwfl_a_SOURCES = dwfl_begin.c dwfl_en
- dwfl_getmodules.c dwfl_getdwarf.c dwfl_module_getdwarf.c \
- dwfl_module_getelf.c dwfl_validate_address.c argp-std.c \
- find-debuginfo.c dwfl_build_id_find_elf.c \
-- dwfl_build_id_find_debuginfo.c linux-kernel-modules.c \
-+ dwfl_build_id_find_debuginfo.c \
- linux-proc-maps.c dwfl_addrmodule.c dwfl_addrdwarf.c cu.c \
- dwfl_module_nextcu.c dwfl_nextcu.c dwfl_cumodule.c \
- dwfl_module_addrdie.c dwfl_addrdie.c lines.c dwfl_lineinfo.c \
-@@ -571,7 +571,6 @@ distclean-compile:
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/lines.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/link_map.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/linux-core-attach.Po@am__quote@
--@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/linux-kernel-modules.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/linux-pid-attach.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/linux-proc-maps.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/lzma.Po@am__quote@
+--- a/libdwfl/Makefile.am
++++ b/libdwfl/Makefile.am
+@@ -49,7 +49,7 @@ libdwfl_a_SOURCES = dwfl_begin.c dwfl_en
+ argp-std.c find-debuginfo.c \
+ dwfl_build_id_find_elf.c \
+ dwfl_build_id_find_debuginfo.c \
+- linux-kernel-modules.c linux-proc-maps.c \
++ linux-proc-maps.c \
+ dwfl_addrmodule.c dwfl_addrdwarf.c \
+ cu.c dwfl_module_nextcu.c dwfl_nextcu.c dwfl_cumodule.c \
+ dwfl_module_addrdie.c dwfl_addrdie.c \