aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils/patches/101-no-fts.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/elfutils/patches/101-no-fts.patch')
-rw-r--r--package/libs/elfutils/patches/101-no-fts.patch18
1 files changed, 11 insertions, 7 deletions
diff --git a/package/libs/elfutils/patches/101-no-fts.patch b/package/libs/elfutils/patches/101-no-fts.patch
index e6a672997d..63699fea26 100644
--- a/package/libs/elfutils/patches/101-no-fts.patch
+++ b/package/libs/elfutils/patches/101-no-fts.patch
@@ -1,6 +1,8 @@
---- a/libdwfl/argp-std.c
-+++ b/libdwfl/argp-std.c
-@@ -52,9 +52,6 @@ static const struct argp_option options[
+Index: elfutils-0.169/libdwfl/argp-std.c
+===================================================================
+--- elfutils-0.169.orig/libdwfl/argp-std.c
++++ elfutils-0.169/libdwfl/argp-std.c
+@@ -56,9 +56,6 @@ static const struct argp_option options[
{ "linux-process-map", 'M', "FILE", 0,
N_("Find addresses in files mapped as read from FILE"
" in Linux /proc/PID/maps format"), 0 },
@@ -10,7 +12,7 @@
{ "debuginfo-path", OPT_DEBUGINFO, "PATH", 0,
N_("Search path for separate debuginfo files"), 0 },
{ NULL, 0, NULL, 0, NULL, 0 }
-@@ -81,15 +78,6 @@ static const Dwfl_Callbacks proc_callbac
+@@ -85,15 +82,6 @@ static const Dwfl_Callbacks proc_callbac
.find_elf = INTUSE(dwfl_linux_proc_find_elf),
};
@@ -26,7 +28,7 @@
/* Structure held at state->HOOK. */
struct parse_opt
{
-@@ -219,43 +207,6 @@ parse_opt (int key, char *arg, struct ar
+@@ -223,43 +211,6 @@ parse_opt (int key, char *arg, struct ar
}
break;
@@ -70,8 +72,10 @@
case ARGP_KEY_SUCCESS:
{
struct parse_opt *opt = state->hook;
---- a/libdwfl/Makefile.in
-+++ b/libdwfl/Makefile.in
+Index: elfutils-0.169/libdwfl/Makefile.in
+===================================================================
+--- elfutils-0.169.orig/libdwfl/Makefile.in
++++ elfutils-0.169/libdwfl/Makefile.in
@@ -120,7 +120,7 @@ am__libdwfl_a_SOURCES_DIST = dwfl_begin.
dwfl_getmodules.c dwfl_getdwarf.c dwfl_module_getdwarf.c \
dwfl_module_getelf.c dwfl_validate_address.c argp-std.c \