aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/elfutils/Makefile')
-rw-r--r--package/libs/elfutils/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index d595e4caf2..b0c9b8bd8c 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -26,6 +26,7 @@ PKG_BUILD_DEPENDS:=!USE_GLIBC:argp-standalone
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
+include $(INCLUDE_DIR)/host-build.mk
define Package/elfutils/Default
SECTION:=libs
@@ -60,6 +61,12 @@ else
CONFIGURE_ARGS += --disable-nls
endif
+HOST_CONFIGURE_ARGS += \
+ --disable-debuginfod \
+ --disable-libdebuginfod \
+ --without-lzma \
+ --without-zstd
+
CONFIGURE_ARGS += \
--program-prefix=eu- \
--disable-debuginfod \
@@ -97,6 +104,7 @@ define Package/libelf/install
endef
# these lines need to be ordered by dependency because of ABI versioning
+$(eval $(call HostBuild))
$(eval $(call BuildPackage,libelf))
$(eval $(call BuildPackage,libdw))
$(eval $(call BuildPackage,libasm))