aboutsummaryrefslogtreecommitdiffstats
path: root/package/kexec-tools
diff options
context:
space:
mode:
Diffstat (limited to 'package/kexec-tools')
-rw-r--r--package/kexec-tools/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/package/kexec-tools/Makefile b/package/kexec-tools/Makefile
index 23294fd39b..d88fc0583c 100644
--- a/package/kexec-tools/Makefile
+++ b/package/kexec-tools/Makefile
@@ -33,12 +33,17 @@ define Package/kexec-tools
URL:=http://www.xmission.com/~ebiederm/files/kexec/README
endef
+MAKE_FLAGS += \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ EXTRA_CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
+ BUILD_CFLAGS="-O2" \
+ LIBS="$(TARGET_LDFLAGS) -lz" \
+ install
+
define Build/Compile
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- install
+ $(call Build/Compile/Default,)
endef
define Package/kexec-tools/install