aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/netfilter.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 22a9f8e2a6..aacf5948b1 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -1167,3 +1167,15 @@ define KernelPackage/nft-fib
endef
$(eval $(call KernelPackage,nft-fib))
+
+
+define KernelPackage/nft-queue
+ SUBMENU:=$(NF_MENU)
+ TITLE:=Netfilter nf_tables queue support
+ DEPENDS:=+kmod-nft-core +kmod-nfnetlink-queue
+ FILES:=$(foreach mod,$(NFT_QUEUE-m),$(LINUX_DIR)/net/$(mod).ko)
+ AUTOLOAD:=$(call AutoProbe,$(notdir $(NFT_QUEUE-m)))
+ KCONFIG:=$(KCONFIG_NFT_QUEUE)
+endef
+
+$(eval $(call KernelPackage,nft-queue))