aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 1f13cb7aa7..43709228f9 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -214,6 +214,22 @@ endef
$(eval $(call KernelPackage,gpio-dev))
+define KernelPackage/gpio-f7188x
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Fintek F718xx/F818xx GPIO Support
+ DEPENDS:=@GPIO_SUPPORT @TARGET_x86
+ KCONFIG:=CONFIG_GPIO_F7188X
+ FILES:=$(LINUX_DIR)/drivers/gpio/gpio-f7188x.ko
+ AUTOLOAD:=$(call AutoProbe,gpio-f7188x)
+endef
+
+define KernelPackage/gpio-f7188x/description
+ Kernel module for the GPIOs found on many Fintek Super-IO chips.
+endef
+
+$(eval $(call KernelPackage,gpio-f7188x))
+
+
define KernelPackage/gpio-mcp23s08
SUBMENU:=$(OTHER_MENU)
TITLE:=Microchip MCP23xxx I/O expander