aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/netsupport.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 97556e459d..27268ee043 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -1443,6 +1443,22 @@ endef
$(eval $(call KernelPackage,inet-diag))
+define KernelPackage/xdp-sockets-diag
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=PF_XDP sockets monitoring interface support for ss utility
+ DEPENDS:=@KERNEL_XDP_SOCKETS
+ KCONFIG:=CONFIG_XDP_SOCKETS_DIAG
+ FILES:=$(LINUX_DIR)/net/xdp/xsk_diag.ko
+ AUTOLOAD:=$(call AutoLoad,31,xsk_diag)
+endef
+
+define KernelPackage/xdp-sockets-diag/description
+ Support for PF_XDP sockets monitoring interface used by the ss tool
+endef
+
+$(eval $(call KernelPackage,xdp-sockets-diag))
+
+
define KernelPackage/wireguard
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=WireGuard secure network tunnel