aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/fs.mk21
-rw-r--r--package/kernel/linux/modules/other.mk35
2 files changed, 56 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index b6d2a120d4..91cf1ea233 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -498,6 +498,27 @@ endef
$(eval $(call KernelPackage,fs-ntfs))
+define KernelPackage/pstore
+ SUBMENU:=$(FS_MENU)
+ TITLE:=Pstore file system
+ DEFAULT:=m if ALL_KMODS
+ KCONFIG:= \
+ CONFIG_PSTORE \
+ CONFIG_PSTORE_COMPRESS=y \
+ CONFIG_PSTORE_COMPRESS_DEFAULT="deflate" \
+ CONFIG_PSTORE_DEFLATE_COMPRESS=y \
+ CONFIG_PSTORE_DEFLATE_COMPRESS_DEFAULT=y
+ FILES:= $(LINUX_DIR)/fs/pstore/pstore.ko
+ AUTOLOAD:=$(call AutoLoad,30,pstore,1)
+endef
+
+define KernelPackage/pstore/description
+ Kernel module for pstore filesystem support
+endef
+
+$(eval $(call KernelPackage,pstore))
+
+
define KernelPackage/fs-reiserfs
SUBMENU:=$(FS_MENU)
TITLE:=ReiserFS filesystem support
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index f712c95c8e..5ccc860790 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -770,6 +770,41 @@ endef
$(eval $(call KernelPackage,mtdram))
+define KernelPackage/ramoops
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Ramoops (pstore-ram)
+ DEFAULT:=m if ALL_KMODS
+ KCONFIG:=CONFIG_PSTORE_RAM
+ DEPENDS:=+kmod-pstore +kmod-reed-solomon
+ FILES:= $(LINUX_DIR)/fs/pstore/ramoops.ko
+ AUTOLOAD:=$(call AutoLoad,30,ramoops,1)
+endef
+
+define KernelPackage/ramoops/description
+ Kernel module for pstore-ram (ramoops) crash log storage
+endef
+
+$(eval $(call KernelPackage,ramoops))
+
+
+define KernelPackage/reed-solomon
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Reed-Solomon error correction
+ DEFAULT:=m if ALL_KMODS
+ KCONFIG:=CONFIG_REED_SOLOMON \
+ CONFIG_REED_SOLOMON_DEC8=y \
+ CONFIG_REED_SOLOMON_ENC8=y
+ FILES:= $(LINUX_DIR)/lib/reed_solomon/reed_solomon.ko
+ AUTOLOAD:=$(call AutoLoad,30,reed_solomon,1)
+endef
+
+define KernelPackage/reed-solomon/description
+ Kernel module for Reed-Solomon error correction
+endef
+
+$(eval $(call KernelPackage,reed-solomon))
+
+
define KernelPackage/serial-8250
SUBMENU:=$(OTHER_MENU)
TITLE:=8250 UARTs