aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/crypto.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/modules/crypto.mk')
-rw-r--r--package/kernel/modules/crypto.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index aaa9d534b2..d17e9c6c2c 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -28,7 +28,6 @@ CRYPTO_MODULES = \
BLKCIPHER2=crypto_blkcipher \
HASH2=crypto_hash \
MANAGER2=cryptomgr \
- CBC=cbc \
ECB=ecb
crypto_confvar=CONFIG_CRYPTO_$(word 1,$(subst =,$(space),$(1)))
@@ -172,6 +171,16 @@ endef
$(eval $(call KernelPackage,crypto-authenc))
+define KernelPackage/crypto-cbc
+ TITLE:=Cipher Block Chaining CryptoAPI module
+ KCONFIG:=CONFIG_CRYPTO_CBC
+ FILES:=$(LINUX_DIR)/crypto/cbc.ko
+ AUTOLOAD:=$(call AutoLoad,09,cbc)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-cbc))
+
define KernelPackage/crypto-des
TITLE:=DES/3DES cipher CryptoAPI module
KCONFIG:=CONFIG_CRYPTO_DES