aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/patches/400-ath_move_debug_code.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/mac80211/patches/400-ath_move_debug_code.patch')
-rw-r--r--package/kernel/mac80211/patches/400-ath_move_debug_code.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/package/kernel/mac80211/patches/400-ath_move_debug_code.patch b/package/kernel/mac80211/patches/400-ath_move_debug_code.patch
deleted file mode 100644
index ed65053d77..0000000000
--- a/package/kernel/mac80211/patches/400-ath_move_debug_code.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/drivers/net/wireless/ath/Makefile
-+++ b/drivers/net/wireless/ath/Makefile
-@@ -13,10 +13,10 @@ ath-objs := main.o \
- regd.o \
- hw.o \
- key.o \
-+ debug.o \
- dfs_pattern_detector.o \
- dfs_pri_detector.o
-
--ath-$(CPTCFG_ATH_DEBUG) += debug.o
- ath-$(CPTCFG_ATH_TRACEPOINTS) += trace.o
-
- CFLAGS_trace.o := -I$(src)
---- a/drivers/net/wireless/ath/ath.h
-+++ b/drivers/net/wireless/ath/ath.h
-@@ -318,14 +318,7 @@ void _ath_dbg(struct ath_common *common,
- #endif /* CPTCFG_ATH_DEBUG */
-
- /** Returns string describing opmode, or NULL if unknown mode. */
--#ifdef CPTCFG_ATH_DEBUG
- const char *ath_opmode_to_string(enum nl80211_iftype opmode);
--#else
--static inline const char *ath_opmode_to_string(enum nl80211_iftype opmode)
--{
-- return "UNKNOWN";
--}
--#endif
-
- extern const char *ath_bus_type_strings[];
- static inline const char *ath_bus_type_to_string(enum ath_bus_type bustype)