aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/other.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 46f5dea7ae..58dd2d6c25 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -41,7 +41,7 @@ define KernelPackage/bluetooth
CONFIG_BT_HCIBTUSB \
CONFIG_BT_HCIBTUSB_BCM=n \
CONFIG_BT_HCIBTUSB_MTK=y \
- CONFIG_BT_HCIBTUSB_RTL=n \
+ CONFIG_BT_HCIBTUSB_RTL=y \
CONFIG_BT_HCIUART \
CONFIG_BT_HCIUART_BCM=n \
CONFIG_BT_HCIUART_INTEL=n \
@@ -56,7 +56,8 @@ define KernelPackage/bluetooth
$(LINUX_DIR)/net/bluetooth/hidp/hidp.ko \
$(LINUX_DIR)/drivers/bluetooth/hci_uart.ko \
$(LINUX_DIR)/drivers/bluetooth/btusb.ko \
- $(LINUX_DIR)/drivers/bluetooth/btintel.ko
+ $(LINUX_DIR)/drivers/bluetooth/btintel.ko \
+ $(LINUX_DIR)/drivers/bluetooth/btrtl.ko
AUTOLOAD:=$(call AutoProbe,bluetooth rfcomm bnep hidp hci_uart btusb)
endef