aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/iio.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/iio.mk b/package/kernel/linux/modules/iio.mk
index afd14ef47b..c0e37f06c7 100644
--- a/package/kernel/linux/modules/iio.mk
+++ b/package/kernel/linux/modules/iio.mk
@@ -566,3 +566,17 @@ define KernelPackage/iio-fxos8700-spi/description
endef
$(eval $(call KernelPackage,iio-fxos8700-spi))
+
+define KernelPackage/iio-ti-am335x-adc
+ TITLE:= TI Sitara AM335x ADC driver
+ DEPENDS:=@TARGET_omap
+ KCONFIG:=CONFIG_TI_AM335X_ADC
+ FILES:=$(LINUX_DIR)/drivers/iio/adc/ti_am335x_adc.ko
+ AUTOLOAD:=$(call AutoProbe,ti_am335x_adc)
+ $(call AddDepends/iio,+kmod-iio-kfifo-buf)
+endef
+define KernelPackage/iio-ti-am335x-adc/description
+ Driver for the TI AM335x ADC.
+endef
+
+$(eval $(call KernelPackage,iio-ti-am335x-adc))