aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/video.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index ee58e97b34..f11431dc2d 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -205,6 +205,22 @@ endef
$(eval $(call KernelPackage,fb-tft))
+define KernelPackage/fb-tft-ili9486
+ SUBMENU:=$(VIDEO_MENU)
+ TITLE:=FB driver for the ILI9486 LCD Controller
+ DEPENDS:=+kmod-fb-tft
+ KCONFIG:=CONFIG_FB_TFT_ILI9486
+ FILES:=$(LINUX_DIR)/drivers/staging/fbtft/fb_ili9486.ko
+ AUTOLOAD:=$(call AutoLoad,09,fb_ili9486)
+endef
+
+define KernelPackage/fb-tft-ili9486/description
+ FB driver for the ILI9486 LCD Controller
+endef
+
+$(eval $(call KernelPackage,fb-tft-ili9486))
+
+
define KernelPackage/drm
SUBMENU:=$(VIDEO_MENU)
TITLE:=Direct Rendering Manager (DRM) support