aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/other.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 38b98f3a10..5ba0e5e420 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -531,6 +531,24 @@ endef
$(eval $(call KernelPackage,rtc-ds1307))
+define KernelPackage/rtc-ds1374
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Dallas/Maxim DS1374 RTC support
+ DEPENDS:=@RTC_SUPPORT +kmod-i2c-core
+ KCONFIG:=CONFIG_RTC_DRV_DS1374 \
+ CONFIG_RTC_DRV_DS1374_WDT=n \
+ CONFIG_RTC_CLASS=y
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-ds1374.ko
+ AUTOLOAD:=$(call AutoProbe,rtc-ds1374)
+endef
+
+define KernelPackage/rtc-ds1374/description
+ Kernel module for Dallas/Maxim DS1374.
+endef
+
+$(eval $(call KernelPackage,rtc-ds1374))
+
+
define KernelPackage/rtc-ds1672
SUBMENU:=$(OTHER_MENU)
TITLE:=Dallas/Maxim DS1672 RTC support