aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/other.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index f05c758340..2cd4765196 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -295,6 +295,24 @@ endef
$(eval $(call KernelPackage,gpio-pcf857x))
+define KernelPackage/gpio-it87
+ SUBMENU:=$(OTHER_MENU)
+ DEPENDS:=@GPIO_SUPPORT @TARGET_x86
+ TITLE:=GPIO support for IT87xx Super I/O chips
+ KCONFIG:=CONFIG_GPIO_IT87
+ FILES:=$(LINUX_DIR)/drivers/gpio/gpio-it87.ko
+ AUTOLOAD:=$(call AutoLoad,25,gpio-it87,1)
+endef
+
+define KernelPackage/gpio-it87/description
+ This driver is tested with ITE IT8728 and IT8732 Super I/O chips, and
+ supports the IT8761E, IT8613, IT8620E, and IT8628E Super I/O chips as
+ well.
+endef
+
+$(eval $(call KernelPackage,gpio-it87))
+
+
define KernelPackage/ppdev
SUBMENU:=$(OTHER_MENU)
TITLE:=Parallel port support