aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/netsupport.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 4653b82565..b739289809 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -46,6 +46,7 @@ define KernelPackage/bonding
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Ethernet bonding driver
KCONFIG:=CONFIG_BONDING
+ DEPENDS:=PACKAGE_kmod-tls:kmod-tls
FILES:=$(LINUX_DIR)/drivers/net/bonding/bonding.ko
AUTOLOAD:=$(call AutoLoad,40,bonding)
MODPARAMS.bonding:=max_bonds=0
@@ -1042,6 +1043,24 @@ endef
$(eval $(call KernelPackage,tcp-bbr))
+define KernelPackage/tls
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=In-kernel TLS Support with HW Offload
+ KCONFIG:=CONFIG_TLS \
+ CONFIG_TLS_DEVICE=y
+ FILES:=$(LINUX_DIR)/net/tls/tls.ko
+ AUTOLOAD:=$(call AutoProbe,tls)
+endef
+
+define KernelPackage/tls/description
+ Kernel module for in-kernel TLS protocol support and hw offload
+ (to supported interfaces).
+ This allows symmetric encryption handling of the TLS protocol to
+ be done in-kernel and it's HW offload when available.
+endef
+
+$(eval $(call KernelPackage,tls))
+
define KernelPackage/tcp-hybla
SUBMENU:=$(NETWORK_SUPPORT_MENU)