aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/usb.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 45c409f4cb..2a5f1d7d5f 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -936,6 +936,7 @@ define KernelPackage/usb-serial-wwan
TITLE:=Support for GSM and CDMA modems
KCONFIG:=CONFIG_USB_SERIAL_WWAN
FILES:=$(LINUX_DIR)/drivers/usb/serial/usb_wwan.ko
+ HIDDEN:=1
AUTOLOAD:=$(call AutoProbe,usb_wwan)
$(call AddDepends/usb-serial)
endef
@@ -949,11 +950,10 @@ $(eval $(call KernelPackage,usb-serial-wwan))
define KernelPackage/usb-serial-option
TITLE:=Support for Option HSDPA modems
- DEPENDS:=+kmod-usb-serial-wwan
KCONFIG:=CONFIG_USB_SERIAL_OPTION
FILES:=$(LINUX_DIR)/drivers/usb/serial/option.ko
AUTOLOAD:=$(call AutoProbe,option)
- $(call AddDepends/usb-serial)
+ $(call AddDepends/usb-serial,+kmod-usb-serial-wwan)
endef
define KernelPackage/usb-serial-option/description