aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/video.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/video.mk')
-rw-r--r--package/kernel/linux/modules/video.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index fcfd5dc596..ee58e97b34 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -183,6 +183,28 @@ endef
$(eval $(call KernelPackage,fb-sys-ram))
+define KernelPackage/fb-tft
+ SUBMENU:=$(VIDEO_MENU)
+ TITLE:=Support for small TFT LCD display modules
+ DEPENDS:= \
+ @GPIO_SUPPORT @!LINUX_3_18 @!LINUX_4_9 +kmod-backlight \
+ +kmod-fb +kmod-fb-sys-fops +kmod-fb-sys-ram +kmod-spi-bitbang
+ KCONFIG:= \
+ CONFIG_FB_BACKLIGHT=y \
+ CONFIG_FB_DEFERRED_IO=y \
+ CONFIG_FB_TFT
+ FILES:= \
+ $(LINUX_DIR)/drivers/staging/fbtft/fbtft.ko
+ AUTOLOAD:=$(call AutoLoad,08,fbtft)
+endef
+
+define KernelPackage/fb-tft/description
+ Support for small TFT LCD display modules
+endef
+
+$(eval $(call KernelPackage,fb-tft))
+
+
define KernelPackage/drm
SUBMENU:=$(VIDEO_MENU)
TITLE:=Direct Rendering Manager (DRM) support