aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/video.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/video.mk')
-rw-r--r--package/kernel/linux/modules/video.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index 232dbd1d34..f726d0ef03 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -187,7 +187,7 @@ define KernelPackage/fb-tft
SUBMENU:=$(VIDEO_MENU)
TITLE:=Support for small TFT LCD display modules
DEPENDS:= \
- @GPIO_SUPPORT @!LINUX_4_9 +kmod-backlight \
+ @GPIO_SUPPORT +kmod-backlight \
+kmod-fb +kmod-fb-sys-fops +kmod-fb-sys-ram +kmod-spi-bitbang
KCONFIG:= \
CONFIG_FB_BACKLIGHT=y \
@@ -447,7 +447,7 @@ define KernelPackage/video-videobuf2
$(LINUX_DIR)/drivers/media/common/videobuf2/videobuf2-v4l2.ko@ge4.16 \
$(LINUX_DIR)/drivers/media/common/videobuf2/videobuf2-memops.ko@ge4.16 \
$(LINUX_DIR)/drivers/media/common/videobuf2/videobuf2-vmalloc.ko@ge4.16
- AUTOLOAD:=$(call AutoLoad,65,videobuf2-core videobuf-v4l2@ge4.4 videobuf2-memops videobuf2-vmalloc)
+ AUTOLOAD:=$(call AutoLoad,65,videobuf2-core videobuf-v4l2 videobuf2-memops videobuf2-vmalloc)
$(call AddDepends/video)
endef