aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index c12150fc5c..a52ba745ef 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1787,8 +1787,10 @@ define KernelPackage/usb-xhci-mtk
DEPENDS:=+kmod-usb-xhci-hcd
KCONFIG:=CONFIG_USB_XHCI_MTK
HIDDEN:=1
- FILES:=$(LINUX_DIR)/drivers/usb/host/xhci-mtk.ko
- AUTOLOAD:=$(call AutoLoad,54,xhci-mtk,1)
+ FILES:= \
+ $(LINUX_DIR)/drivers/usb/host/xhci-mtk.ko@lt5.13 \
+ $(LINUX_DIR)/drivers/usb/host/xhci-mtk-hcd.ko@ge5.13
+ AUTOLOAD:=$(call AutoLoad,54,xhci-mtk@lt5.13 xhci-mtk-hcd@gt5.13,1)
$(call AddDepends/usb)
endef