aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 8a4915712b..61a876b4d9 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -318,6 +318,17 @@ define KernelPackage/usb-bcma
endef
$(eval $(call KernelPackage,usb-bcma))
+define KernelPackage/usb-fotg210
+ TITLE:=Support for FOTG210 USB host controllers
+ DEPENDS:=@USB_SUPPORT @TARGET_gemini
+ KCONFIG:=CONFIG_USB_FOTG210_HCD
+ FILES:= \
+ $(if $(CONFIG_USB_FOTG210_HCD),$(LINUX_DIR)/drivers/usb/host/fotg210-hcd.ko)
+ AUTOLOAD:=$(call AutoLoad,50,fotg210-hcd,1)
+ $(call AddDepends/usb)
+endef
+$(eval $(call KernelPackage,usb-fotg210))
+
define KernelPackage/usb-ssb
TITLE:=Support for SSB USB controllers
DEPENDS:=@USB_SUPPORT @TARGET_brcm47xx