aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk9
1 files changed, 2 insertions, 7 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index c86470059e..9dbf06264b 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -16,15 +16,10 @@ define KernelPackage/usb-core
TITLE:=Support for USB
DEPENDS:=@USB_SUPPORT
KCONFIG:=CONFIG_USB CONFIG_XPS_USB_HCD_XILINX=n CONFIG_USB_FHCI_HCD=n
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.16.0)),1)
FILES:= \
$(LINUX_DIR)/drivers/usb/core/usbcore.ko \
- $(LINUX_DIR)/drivers/usb/common/usb-common.ko
-else
- FILES:= \
- $(LINUX_DIR)/drivers/usb/core/usbcore.ko \
- $(LINUX_DIR)/drivers/usb/usb-common.ko
-endif
+ $(LINUX_DIR)/drivers/usb/usb-common.ko@lt3.16 \
+ $(LINUX_DIR)/drivers/usb/common/usb-common.ko@ge3.16
AUTOLOAD:=$(call AutoLoad,20,usb-common usbcore,1)
$(call AddDepends/nls)
endef