aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk20
1 files changed, 11 insertions, 9 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index cd827725bd..9c10b97501 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1013,31 +1013,33 @@ define KernelPackage/zram/description
endef
define KernelPackage/zram/config
- choice
- prompt "ZRAM Default compressor"
- default ZRAM_DEF_COMP_LZORLE
+ if PACKAGE_kmod-zram
+ choice
+ prompt "ZRAM Default compressor"
+ default ZRAM_DEF_COMP_LZORLE
- config ZRAM_DEF_COMP_LZORLE
+ config ZRAM_DEF_COMP_LZORLE
bool "lzo-rle"
select PACKAGE_kmod-lib-lzo
- config ZRAM_DEF_COMP_LZO
+ config ZRAM_DEF_COMP_LZO
bool "lzo"
select PACKAGE_kmod-lib-lzo
- config ZRAM_DEF_COMP_LZ4
+ config ZRAM_DEF_COMP_LZ4
bool "lz4"
select PACKAGE_kmod-lib-lz4
- config ZRAM_DEF_COMP_LZ4HC
+ config ZRAM_DEF_COMP_LZ4HC
bool "lz4-hc"
select PACKAGE_kmod-lib-lz4hc
- config ZRAM_DEF_COMP_ZSTD
+ config ZRAM_DEF_COMP_ZSTD
bool "zstd"
select PACKAGE_kmod-lib-zstd
- endchoice
+ endchoice
+ endif
endef
$(eval $(call KernelPackage,zram))